Not logged in
 
Author
Topic: SONY VPL-CS1 * HAS BLUE HUE*
member
Joined: Nov 25, 2005
Posts: 2
Reply to PostAlert Moderator
I have a sony vpl-cs1 lcd data projector that I have used for 4 years.just after 3rd year I started to get a blue hue spot on picture image. The image could be actually focused in on and looked like some sorta water spot.I have taken projector apart 4 times as far as i could break down lens and cleaned them,but didnt help.I bought a new bulb for $325 and was dismayed 2 discover problem didnt go away. The image is still a crisp clear image ,it just has a blue haze on most of projection now. Over time the hue has grown to most of the image except for top corners(they are still clear and very sharp. Can anyone enlighten me what may be problem?I dont have the $ to replace this toy, and I wonder if its a common problem . I hope I dont need some sorta LED display circuit board or something. THANKS IN ADVANCE
moderator
Joined: Mar 28, 2005
Posts: 12,357
Reply to PostAlert Moderator
The blue polarizer sounds like it is bad. I believe the going rate on the Sanyo that has this issue is about a $500.00 repair.



You can always try to get the polarizer yourself and replace it yourself. That's what I'd do since $500.00 is more than a downpayment on a brand new unit. I am unaware of where/how you would get the polarizer though.
AV Integrated - Theater, whole house audio, and technology consultation during the build and installation process in the Washington, DC metropolitan area.
member
Joined: Nov 25, 2005
Posts: 2
Reply to PostAlert Moderator
I have researched more since posting and found under reviews,that some other people have had same problem,,and like they say,Sony dont really care,,send it in and they will try 2 repair but costly! i downloaded the parts list 4 it and am looking now 4 some sorta blue polar chip or circuit like u said.