Not logged in
 
Author
Topic: Optoma DV10 no power
member
Joined: Jun 22, 2014
Posts: 2
Reply to PostAlert Moderator
I have a MovieTime DV10 and it has been working great for years and I just used it last week with no problems, now when I plugged it in - NOTHING, no power getting to the machine. I tried multiple outlets with no luck. I used the power cord on my computer and it powered up no problem, so it is not the cord. ???
Any help would be appreciated.
moderator
Joined: Mar 28, 2005
Posts: 12,357
Reply to PostAlert Moderator
There is no specific answer on this one. It most likely is the internal power supply, which would be a good thing because that's not terribly expensive to replace, but considering the age of the projector, it would be something you should try fixing yourself.

As I am not a projector technician, I don't have any real specifics for you, you should search online, but typically the power supply is easy to recognize, and replacement supplies may be difficult, but not impossible to locate.

Still, considering the age of the projector... it may be time to replace it.
AV Integrated - Theater, whole house audio, and technology consultation during the build and installation process in the Washington, DC metropolitan area.
member
Joined: Jun 22, 2014
Posts: 2
Reply to PostAlert Moderator
Quote (AV_Integrated on Jun 22, 2014 6:44 PM):
There is no specific answer on this one. It most likely is the internal power supply, which would be a good thing because that's not terribly expensive to replace, but considering the age of the projector, it would be something you should try fixing yourself.

As I am not a projector technician, I don't have any real specifics for you, you should search online, but typically the power supply is easy to recognize, and replacement supplies may be difficult, but not impossible to locate.

Still, considering the age of the projector... it may be time to replace it.

Thanks AV, appreciate the response and suggestion - have my fingers crossed it is that easy