Not logged in
 

Posts referring to the Hitachi PJTX100 UltraVision

Click the topic name to jump to the matching post
Jump to page: <<<12345>>> (7 total)
Topic:   Hitachi PJ-TX100 shows yellow image even if not connected

I just bought a used Hitachi PJ-TX100, which shows images with a uniform yellow shade. I would exclude that the VGA cable or connector is faulty, because the image looks yellow even when it's not connected to any source. The guy who sold it to me said that the lamp is old and needs replacement, but unfortunately I don't know how many hours it run, because the timer has been reset. Is it possible that is just the lamp, which needs to be replaced or should I take in consideration a bigger issue?
Forum: Projectors
 
Topic:   Replace Lamp or Buy New Projector?

First every post to this forum, looking for good advice on whether I should replace my lamp for +/-$300 or buy a new projector. My current projector is a Hitachi PJ-TX100 which I've had for about 6 years. Has been a good performer and very pleased with the picture quality. I'm in a dedicated theater room measures about 13'x20'. Majority of use is for Sunday football and family movies 1 or 2 a week. Given the technology has greatly improved over the past 6 years I'm really struggling to spend 300 on a lamp when I could spend a few more dollars in get a much better projector. I believe the max resolution on this projector is 720p. 1 - Would like your thoughts on value of upgrading vs. lamp replacement. 2 - If I would replace my existing projector, what is a comparable projector to purchase with better resolution and features? Thanks in advance for your input.
Forum: Projectors
 
Topic:   Why can't my HD Ready projector display HD?

Hi, I've finally upgraded to a Blu Ray player (got an LG BD560), but my projector (Hitachi PJ-TX100, which is HD Ready with an HDCP compliant DVI-D input) shows no image at all when I connect it up via an HDMI -> DVI-D cable. Component working fine (although you can't view HD resolution over component, it seems, due to copyright protection). The same HDMI -> DVI-D cable, plugged into my computer screen, shows an image perfectly, and I've tried 2 different cables. So the problem presumably lies with the projector. I've tried all the different resolution and colour settings on both the projector and the player (although 720p is what it should be) - nothing! I get this problem on the Blu Ray menu screen as well as when I try to play Blu Rays, so it's not a copy protection issue. Really hoping I can get this sorted as don't want to have to sink another grand on a new projector just because my old Hitachi is being difficult about HD input! Thanks for your help.
Forum: Projectors
 
Topic:   My old Hitachi PJ Tx 100 has a purple circle in the middle

I have pretty much the same thing. Owned it three years, just changed the lamp. Instead of one giant purple splotch, I have a general miasmal of slight purple splotches across the whole screen. Guess I should have bought that other warentee. Oh well. For all of that, it still works well and I'm happy with it. Is this common to LCD projectors in general, or is it something that has been fixed in the last few years. I say this as I am considering buying a new projector in about a year or so and I wanted to start gathering data.
Forum: Projectors
 
Topic:   My old Hitachi PJ Tx 100 has a purple circle in the middle

Dear all, After 3 years of intense use, my Hitachi PJ TX 100 started to develop a purple circle, especialy visible on a white background. I thought it was my old lamp, but after changing the lamp today, the circle is still there. It is visible on about 50% of my screen, right in the middle. Does anyone know what I can do about it? Or is this normal for a projector this age? Thanks, Heimen.
Forum: Projectors
 
Jump to page: <<<12345>>> (7 total)