Not logged in
 

Posts referring to the Proxima DP9270

Click the topic name to jump to the matching post
Topic:   Proxima desktop projector 9270

AV_integrated is right. There are a lot of variables that could make the projector act like this. Is it possible for you to upload a few still shots or better yet a short clip of what is going on with your projector when you attempt to turn the device on? Have you been able to check the Lamp hours on the projector? The first thing and easiest thing to go out is the lamp bulbs on a projector. If you are able to do this it may save a lot of time and money before you get a professional analysis on the device. The next step I'd take would be to make sure that the power supply is 100% intact, meaning any connections are firmly in place and not loose. You should also just do a quick physical check and make sure your projector's power supply is no getting hot or other parts of the projector overheating. Lastly, locate any potential fuses that the device may have and identify any discoloration or burnt out filaments the fuse may contain. By the way, if you are ever in the need for a temporary projector to hold you until you get the Proxima DP9270 issue resolved, take a look a renting one in the mean time, they really come in handy. Projector Rentals: http://aarental.com/projector-rental/ If you have any more questions, please ask, I will try to assist you as much as possible. Ben Lead AV Tech, AA Rental
Forum: Projectors
 
Topic:   Proxima desktop projector 9270

Hey everyone :-) My projector had been working great as my entertainment screen for everything however yesterday i went to turn it on and it went to start up, I could see the light come on as if it was going to start up by looking into the lens. Then like two seconds in the light turns offand the fan kicks in and its really loud and blows for about a min or two then turns off like its ready to be turned back on. I took all the covers off and sprayed dust off on it and cleaned the filters. I even pulled the light out and then put it all back together. IT WORKED!.. Till i turned it off and then when i went to turn it on again the same thing is happening :( i again took it all apart and put it all back together but still does not work. Does anyone know the problem? Thanks in advance
Forum: Projectors